MyAccount Unavailable
Incident Report for Zetta Status Page
Resolved
This incident has been resolved.
Posted Nov 01, 2019 - 16:55 AWST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 01, 2019 - 16:50 AWST
This incident affected: Global (MyAccount Portal (account.zettagrid.com)).