Mobile Broadband Service Interruption
Incident Report for Zetta Status Page
Resolved
Issues impacting Mobile Broadband services have been resolved and all services restored. If you're continuing to experience difficulties please power cycle your hardware and contact the Operations Centre on 1300 139 550 or by email to support@zetta.net.au.
Posted 5 days ago. Sep 11, 2019 - 07:52 AWST
Investigating
Some customers may be experiencing difficulties connecting to Mobile Broadband services. Upstream provider is currently investigating the issue.

A further update will be posted as soon as more information is available.
Posted 5 days ago. Sep 11, 2019 - 01:49 AWST
This incident affected: Australia - Queensland (Wireless), Australia - Victoria (Wireless), Australia - New South Wales (Wireless), and Australia - Western Australia (Wireless).