Zettagrid AUS "My Account" Unavailable
Incident Report for Zetta Status Page
Resolved
My Account page access issues should now be resolved for all users. If you are continuing to have issues in accessing the My Account page please contact our support team.
Posted 9 days ago. Aug 12, 2019 - 10:21 AWST
Investigating
The Zettagrid "My Account" portal is currently unavailable. Engineers are investigating.
Posted 9 days ago. Aug 12, 2019 - 10:03 AWST
This incident affected: Global (MyAccount Portal (Australia)).