Cibitung Zone - Veeam Cloud Connect Replication Emergency Maintenance
Incident Report for Zetta Status Page
Resolved
This incident has been resolved.
Posted 17 days ago. Aug 29, 2019 - 11:08 AWST
Investigating
Engineers have been alerted to an issue that requires a brief maintenance period to resolve. Updates will be posted once complete.
Posted 18 days ago. Aug 28, 2019 - 11:44 AWST
This incident affected: Indonesia - Cibitung (Veeam Backup and Replication).