Simtex Website and Management Portal Disruption
Incident Report for Zetta Status Page
Resolved
Access to Website and My Account Portal has now been restored.
Posted Feb 04, 2020 - 07:55 AWST
Investigating
Engineers are investigating loss of access to Simtex website and My account portal. If your request is urgent, please contact support on 1300 888 519 or support@simtex.com.au.
Posted Feb 04, 2020 - 07:11 AWST